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Important Information

No offer or solicitation to buy or sell securities, securities derivative or futures products of any kind, or any type of trading or invest-
ment advice, recommendation or strategy, is made, given or in any manner endorsed by TradeStation or any TradeStation affiliate
and the information made available on this Website is not an offer or solicitation of any kind in any jurisdiction where TradeStation
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you trade (equities, options or futures); therefore, you should not invest or risk money that you cannot afford to lose. Options trad-
ing is not suitable for all investors. Your account application to trade options will be considered and approved or disapproved based
on all relevant factors, including your trading experience. View the document titled Characteristics and Risks of Standardized
Options. Before trading any asset class, customers must read the relevant risk disclosure statements on our Important Information
page. System access and trade placement and execution may be delayed or fail due to market volatility and volume, quote delays,
system and software errors, Internet traffic, outages and other factors.

The Company and its representatives do not provide "fiduciary" investment advice or recommendations to employee benefit plans,
participants or beneficiaries under the Employee Retirement Income Security Act of 1974 (ERISA or the Act), or owners of indi-
vidual retirement accounts (IRAs) under the Internal Revenue Code of 1986 (Code). Neither the Company, nor any of its asso-
ciated persons, registered representatives, employees, or affiliates offer investment advice or recommendations. The Company
may provide general information to potential and prospective customers for the purposes of making an informed investment
decision on their own. The information provided is not intended to be investment advice, nor does it fall within the definition of
investment advice or recommendations as defined by the Department of Labor’s fiduciary and best interest standards.

TradeStation Group, Inc. Affiliates: All proprietary technology in TradeStation is owned by TradeStation Technologies, Inc. Equit-
ies, equities options, and commodity futures products and services are offered by TradeStation Securities, Inc. (Member NYSE,
FINRA, CME and SIPC). TradeStation Securities, Inc.’s SIPC coverage is available only for equities and equities options
accounts.
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then select Help > Get Help > Platform Trading.
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About Chart Analysis

The Chart Analysis window is used to graphically display price data, perform technical analysis, back-test and automate
strategies, and show orders and positions for a specified symbol. Chart analysis windows are created and saved as part of a work-
space allowingmultiple chart windows to be combined with other tool windows in each workspace.

To create a Chart Analysis window, click the Chart Analysis icon from the Apps tab, or use theMain File > New Applic-
ation > Chart Analysis menu sequence. A new Chart Analysis window is displayed.

VIDEO - Creating a Chart Analysis Window

Chart Window Layout

Themain portion of the chart window displays the price chart with its status line and associated price and time axes. You can scroll
the chart left and right to view price history and use the crosshairs pointer (with datatip) to review details for a selected bar and
price point. Sub-graphs may appear beneath the price chart if you have added studies or price data for other symbols.

The following numbered items refer to features in the picture (above):

Toolbar

Provides drop downmenus that control the features and settings of the window.

Price Chart

The price chart displays a series of bar values that summarizemarket prices based on the trading interval selected for the cur-
rent chart symbol. Trading intervals can be time-based (5minute, 30minutes, daily, etc.), activity-based (ticks, volume), or
price-based (Point-and-Figure, Kagi, etc.). You can select the bar style (OHLC, candlestick, line-on-close, etc.) used to rep-
resent the interval as well as choosing custom display settings such as color, line type, etc.



Sub-graph

A subgraph will appear beneath the price chart for each applied study that requires its own price axis scale, such as volume or
a reference indicator such as ADX. Sub-graphs are also used to display additional symbols or intervals. A maximum of 16 sub-
graphs can appear in the chart window. SeeWorking with Sub-graphs for more information.

Status Line

A status line appears at the top of each price chart and subgraph. It displays information about the symbol and/or studies and
strategies applied to the chart or subgraph. For example, for a symbol you will see the name, interval, and exchange along with
it's current prices, bid-asks, session high-lows, and volume. For studies and strategies you will see each listed by name along
with a summary of it's input settings and plotted values. For more information, see Chart Status Line.

Price Axis

The price axis (y-axis) of the chart window displays the range of prices for the symbol in a price chart and any plotted values in
a subgraph.

Time Axis

The time axis (x-axis) shows the time scale (interval) of the bars displayed in the chart window.

Scroll Bar

The horizontal scroll bar appears when a price chart contains bar data that does not fit in the current chart window. Drag the
scroll bar slider to the left or right to view more bars, or use the left/right arrow keys to perform the same function. The up/down
arrows keys are used to change the bar spacing allowing you to control the number of bars that are visible in the chart window.

Crosshairs (Pointer)

Clicking the chart pointer in an open area of the chart displays crosshairs at the location of the pointer. The horizontal line let
you identify a price level on the price axis and the vertical line aligns with the nearest bar to show its position on the time axis.
For more information, see About Pointers.

DataTip

The DataTip shows information relative to the position of the crosshairs pointer in a price chart or subgraph. For example,
when themouse button is clicked near a particular bar in a price chart, a summary of that bar's prices and volume is displayed
along with the values of any studies applied to that set of bars. For more information, see Viewing Price Data in the DataTip.

Chart Analysis Tools

A variety of charting tools can be applied to a chart to help youmeasure and analyzemarket movement, backtest andmange rule-
based trading, andmonitor orders and current positions.

Studies

Studies are used to evaluate historical and real-timemarket data. Applying a study to a chart provides you with a visual
method of monitoring andmeasuring the symbol's pricemovement and financial performance. Studies can be an Indicator,
ShowMe, PaintBar, ActivityBar, ProbabilityMap and Study Groups. For more information, see About Studies.

Strategies

Strategies consist of a set of rules that can be based on pricemovement, volatility and interest rate changes, and other market
conditions for a charted symbol. They allow you to develop and back-test your trading ideas and, when appropriate, automate
buy/sell signals and order generation. When strategies are applied to a chart, onscreen cues are displayed (arrows, flags, num-
bers and order names) to show you when your strategy rules would have historically placed trades. Once you apply a strategy



to a chart, you canmodify the general, back-testing, automation and optimization settings. For more information, see About
Strategies.

Drawing Tools

Drawing tools are used to visually highlight information on a chart. Some drawing tools, such as trendlines, let you connect mul-
tiple price points to help you analyze the direction or amount of pricemovement. Non-analytical drawing objects, such as
boxes or text objects, call attention to an area of a chart, yet have no specific market interpretation. Drawing objects applied to
a chart can bemoved, formatted, and stay aligned with new price bar data when the symbol's interval is changed. For more
information, see About Drawing Objects.

Account Orders & Positions

Account order & positionmarkers on a chart provide a convenient way tomonitor the status of your orders and positions for the
charted symbol. Order markers show you the target price for an open limit or stop order. Positionmarkers point to the price on a
bar where an order is filled and show the type of order along with its size in shares/contracts. For more information, see About
Account Orders & Positions.

Chart Trading

Chart Trading is a built-in study that allows you to quickly places trades, manage orders, andmonitor positions directly on a
chart. For more information, see Using Chart Trading.

Creating and Customizing a Chart

The following steps will assist you in creating and customizing a chart:

1. Click the Chart Analysis icon on the Apps tab. The Chart Analysis window appears in your workspace and you are ready
to customize your chart.

2. To change the symbol on the chart, type the symbol name (which appears in the toolbar's command line) and press ENTER.
If you do not know the symbol name, click the Symbol Lookup icon to search the symbol by name or description.

3. Use the Style menu to select a bar or chart type (Candlestick,OHLC, Kagi, etc.).
4. Use the Data > Edit Symbolmenu sequence and select the Settings tab to change the symbol Settings for selected chart

type. The range values let you decide how much historical data you want to appear in the chart window. Depending on the
interval or chart type you select, will determine the amount of historical data is displayed.

5. Use the Timeframe menu to change the bar interval for the specified bar or chart type, Or, type the interval keyword (i.e. 5
min, 10min, daily, etc.) and press ENTER (the interval appears in the toolbar's command line). By default, intra-day (time) is
displayed when a chart is created. For more information on interval, interval/chart types and range, see Timeframes (Data
Intervals).

6. Once you have specified your chart settings, you can use the Data > Edit Symbol menu sequence and select the Scaling
tab to change the symbol Scaling settings for the chart.

To apply the changes youmade for future charts, select the Set as Default check box in each customize dialog.

Related Topics

Chart Types

Timeframes (Data Intervals)

Customizing a Symbol in a Chart

Customizing a Chart Analysis Window

Adding Studies to a Chart or GridWindow



Clicking and Dragging in a Chart

About Scaling in Price Charts

Overlaying Symbols on a Chart

Changing the Vertical Axis Settings on a Chart

Creating aMulti-Data Chart

Removing a Symbol in aMulti-Data Chart

Using Chart Trading (trading from aChart)

About Account Orders & Positions

See Also

About the Download Scheduler

About the DataWindow

Toolbars

About Windows

Refreshing TradeStationWindows

PrintingWindows and Documents

About the EasyLanguage UtilizationMonitor

Similar functionality is available in theMobile andWeb Trading versions of TradeStation.



Chart Types

There are several types of charts you can create in TradeStation:

l Bar Chart
l Candlestick Chart
l Kagi Chart
l Kase Bar Chart
l Line Chart
l Line Break Chart
l Momentum Bar Chart
l Point & Figure Chart
l Range Bar Chart
l Renko Chart

Related Topics

About Chart Analysis



About Drawing Objects

Your charting application contains drawing objects that can be applied, moved, and formatted, directly on a chart, providing tre-
mendous flexibility. When you change the data interval of your chart, your charting application automatically readjusts your draw-
ing object. In addition, many drawing objects allow you to analyze new data on a chart by extending the drawing object to the right
of the chart. Drawing objects cannot be included as part of a study group.

There are two different types of drawing objects:

l Non-analytical - Such as the arc, arrow, text, and ellipse offer no specific market interpretation. You can use them to call
attention to an area of a chart you consider worth noting. For example, youmay want to highlight an area of your chart you
want to review later using the rectangle drawing object. Youmight also want to write text on the chart to remind yourself about
amarket condition to watch for or as a label to include when you print a chart.

l Analytical - Such as the Fibonacci Cycle, Percent Retracement, andGann Fan perform calculations to analyze the price data
where they are drawn. Most analytical drawing objects can also alert you when certain market conditions occur such as price
breakouts.

You can also set alerts for drawing objects. You can choose to be alerted by a visual alert, sound notification, or email message
when the alert criteria aremet. This way you can keep up-to-date on important changes in themarket nomatter where you are. For
more information, see About the TradeStationMessage Center.

Each drawing object applied to a chart is assigned an identification number (ID#). As you place drawing objects on a chart, these
numbers are assigned in sequence, starting with 1. Identification numbers are used in theMessage Center to identify which draw-
ing object generated an alert, in the DataWindow to reference the values of a specific drawing objects, and in EasyLanguage to ref-
erence specific trendline and text drawing objects.

To view information on the drawing object applied to a chart, place your pointer on the drawing object and press and hold the right
mouse button. Information specific to the drawing object is displayed as a DataTip.

When you apply a drawing object to a chart, it is associated with a specific data stream in the chart (for example, Data1, Data2,
Data3, etc). If you replace or delete the associated data stream, the drawing object disappears. If replacing the data stream, you
will need to redraw that object for the new symbol. However, the drawing object will reappear if you reapply the original data
stream.

By default, your pointer remains in Drawingmode after applying a drawing object. While in Drawingmode, you will not be able to
select other objects on the Chart Analysis window (for example, other drawing objects or price data). However, you can choose
any other command from amenu or toolbar. Since each drawing object is unique, it is best to use the DrawingObject Library to loc-
ate the drawing object you want to learnmore about.

You can also use the shortcut menu on a selected object component (identified with small square) to change the drawing
properties such as Color, Style, Weight, and any object specific settings.

Related Topics

Drawing Object Library

SnapMode

Parallel Drawing Object

Using Alerts with Drawing Objects

Deleting Drawing Objects



Adding Studies to a Chart or Grid Window

TradeStation provides a large selection of studies that can be used to analyze data. These include indicators, ShowMe and
PaintBar studies, ActivityBar studies, and ProbabilityMap studies. You can change the parameters (inputs) used in the calculation
of a study or trading strategy to better suit your own trading objectives. Adding studies into your Chart or Grid window can also help
you evaluatemarket actions that can be used later when building trading strategies.

VIDEO - Adding Indicator Studies to Chart Analysis

The studies you decide to apply to your market data, as well as the interpretation of what pricemovement andmarket trend
they illustrate, are subjective and ultimately determined by the investor or trader who is studying that market.

1. From an active chart or grid window, access the Studies > Add Study menu sequence.
2. Select the study type tab (Chart) or study type drop-down items (RadarScreen/Quotes) to display a list of study names.
3. Select the desired study (or studies) to add to the active chart or grid.

Definition - Launches the Help topic for the selected study name.

Edit EasyLanguage - Opens the EasyLanguage document for the selected study name in the TradeStation Devel-
opment Environment.

Import - Imports a study provided by a 3rd part from the TradeStation website or using the Import Wizard.

3. In RadarScreen, click Add tomove the selected studies from Available to Selected. Remove moves Selected studies back
to Available.

4. Optional. Check Prompt for Editing (Chart) or Customize (RadarScreen) to edit the settings for selected studies before they
are added.

5. Click OK to add the selected items or Cancel to exit without any changes.

Related Topics

About Studies

About Indicators

About ShowMe and PaintBar Studies

About ActivityBar Studies

About ProbabilityMap Studies

About Chart Analysis

About RadarScreen



Enabling and Disabling Alerts for a Study

Many studies have alert criteria written into them; once you enable the alert for the study, then whenmarket activity on the last bar
of the chart meets the criteria specified by the study, an alert is triggered.

Your analysis application checks for alert conditions when you first apply the study to the app. Thereafter, it will check for alert con-
ditions when:

l The price data is updated.
l You open the workspace containing the study.
l You replace the symbol with another symbol.

In order to monitor alerts, make sure you enable the Update on every tick option. If not, studies are recalculated only at the close of
the bar. When an alert is triggered, the details of the alert are posted to theMessage Center. By default, you are also notified by
means of an audible beep and an Alert Notification window. However, you can choose what type of notification you want to receive
- an email message, visual alert, or sound notification. For instructions for changing the way you are notified and on how to use the
Message Center to monitor your alerts, see About the TradeStationMessage Center.

1. Access the Studies > Edit Studies menu sequence. The Customize Studies & Strategies dialog is displayed.
2. Click the Studies tab.
3. Select the study tomodify.
4. Click Customize.
5. Click the Alerts tab.

See Customize Study - Alerts to set drawing object alerts.

6. Click Default to use the settings as the default for all future studies of this type.
7. Click OK when finished.

Related Topics

About Studies



Creating a Multi-Data Chart

You can plot more than one symbol in the sameChart Analysis window.

By default, each additional symbol will plot underneath the other in a separate subgraph. You will begin with a chart analysis win-
dow that already has a symbol plotted (base price data) then add a second symbol to the Chart Analysis window without replacing
the first symbol.

VIDEO - Multiple Symbol Analysis in Chart Analysis

1. Activate a Chart Analysis window.
2. From themenu, click Data > Add Symbol. The Add Symbol dialog is displayed.

3. Enter the symbol in the Symbol box or select one from the drop-down list. Click Lookup to do a symbol search.
4. To customize the symbol, select the Prompt for Editing check box. If you do not select the check box, the symbol is plotted

using the default settings.
5. Click Plot. If the Prompt for Editing check box is selected, the Customize Symbol [symbol] dialog is displayed.

The additional symbol will be plotted in a new subgraph in the Chart Analysis window.

You cannot combine a symbol using a tick-based data interval with any other type of data interval (for example, you cannot
plot one symbol as a 1-tick chart and the other as a 5-minute chart). You can not combine Point & Figure charts with other
data intervals.

Related Topics

Overlaying Symbols on a Chart

Removing a Symbol in aMulti-Data Chart

"About Chart Analysis" on page 5



About Strategy Testing

Testing a strategy is a two-step process. First, test your trading rules on historical data (also called backtesting) to examine the res-
ults that are generated. Once they perform sufficiently to your requirements, you can apply the rules in a TradeStation Chart Ana-
lysis window and automate them to see how they perform in real-time. Complete strategy testing involves both historical and real-
time evaluation.

To back test your strategy on historical data, you apply a strategy to a Chart Analysis window and TradeStation automatically
reviews every entry and exit signal and graphically displays them on the screen. You should come to an understanding of how your
strategy enters and exits trades as well as other behaviors. If you find that your trading strategy fits your trading personality, you
may feel confident in using the strategy tomake future trading decisions.

To test-trade your strategy, you can automate the strategy so it automatically generates new entry and exit signals as they occur.
You can then evaluate exactly where the trades occurred and at what price. For more information, see Automating a Strategy.

The Strategy Performance Report provides detailed information about the strategy. This report may be used to help decide if the
trading strategy is right for you. When testing a strategy, youmay factor in the costs of your trades-costs such as broker's com-
missions, slippage, andmargin. This may help you ensure that the profit and loss figures reported in the Strategy Performance
Report are as realistic as possible.

For more information, see About the Strategy Performance Report.

Related Topics

Inserting a Strategy

About the Strategy's Onscreen Cues

Customizing Studies and Strategies

Removing a Strategy

Changing the Status of a Strategy

About the Strategy Performance Report

About Chart Analysis



About the Strategy Performance Report

The Strategy Performance Report (SPR) is used to analyze the performance of a strategy as well as to gain a better understanding
of its characteristics. Once you apply an entry and exit strategy to a chart, the Strategy Performance Report enables you to view
strategy information such as total net profit, total number of trades, largest losing trade, andmore.

Access from aChart Analysis window using the Data > Strategy Performance Report menu sequence. The Strategy Per-
formance Report window is displayed. Note that youmust already have strategy trades in your chart to see report data.

The Strategy Performance Report allows you to view a detailed report of all trades generated by your strategy's criteria. It provides
over 100 performance fields including several graphs.

If the symbol associated with your strategy trades in a different currency than that of the brokerage account used for the trade, you
will have the option of selecting either Symbol () or Account () from the SPR menu to change the report currency.

In addition to sending the report to a printer, the report can be saved as an Excel spreadsheet for further analysis or as a single
html-based web archive file for easy storage, sharing, and/or future reference and graphing. Use the Save icon on the SPR toolbar
to select an export file format.

Related Topics

Strategy Performance Report Tabs and Fields

Customize Report Settings

Printing a Report

Saving a Report

http://help.tradestation.com/09_05/eng/tradestationhelp/subsystems/spr_topics/spr/strategy_performance_report_tabs_and_fields.htm
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