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Welcome to the Learning TradeStation series. Themain topics in this lesson are included below for your easy reference, and the
complete links for more features are available in the TradeStation® platform help system.

To access the topics directly on your desktop, navigate to the topMenu bar within the TradeStation platform,
then select Help > Get Help > Platform Trading.
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About the Trade Bar

The Trade Bar allows you to efficiently place discretionary trades as well as customize strategy-generated orders. You can place
market, limit, stopmarket, and stop limit orders for listed securities directly into themarket. The Trade Bar works in conjunction
with the TradeManager window, where all of your trading activity is logged in real-time. For more information on the TradeManager
window, see About TradeManager.

The Trade Bar input fields and controls for the selected Order Type.

Although the specific inputs will vary based on the type of instrument you select, the upper area of the Trade Bar contains the fields
where you enter information about your order, such as symbol, quantity, and duration.

Themiddle area of the Trade Bar contains the buttons that you use to actually place a buy or sell order.

The lower area of the Trade Bar also contains theMessage box, where important information about your trading activity is dis-
played. All messages displayed in theMessage box are logged to the TradeManager - Messages tab in the TradeManager window.

Related Topics

Trade Bar Buttons and Fields

Displaying or Hiding the Trade Bar

Customizing the Trade Bar

Setting Order Entry preferences

About OCO/OSO Trade Bar

About StagedOrders

Equities Orders

Placing an Equities Order

Canceling an Equities Order

Options Orders

Placing Single-LegOrders

PlacingMulti-Leg SpreadOrders

Canceling anOptions Order

Forex Orders

Placing a Forex Order

Canceling a Forex Order



Similar functionality is available in theMobile andWeb Trading versions of TradeStation.



About Matrix Orders

TradeStation clients can use theMatrix window to rapidly place or change orders without the Trade Bar. Thematrix can be used to
directly place orders for Stocks by simply loading the appropriate symbol and using one of the following order selectionmethods.

Buy Orders - Auto Order Type or Limit & Stop

Example: If you are buying below the last price, it will be a buy limit order.

To quickly place a Buy order using the current order settings (Order Type, Quantity, Duration, etc.), click on the cell in the Bid Size
column that corresponds to the price at which you want to buy (cover). If the order type Auto (LMT/STP) or Auto (LMT/STL) has
been selected, theMatrix will automatically specify a Buy Limit, Buy Stop-Market, or Buy Stop-Limit order based on whether the
selected Bid Size is above or below the current price. If the order type Limit, StopMarket, or Stop Limit is selected, the Buy order
will always be of that type.

VIDEO - Placing Limit and Stop Orders Using the Matrix

Sell Orders - Auto Order Type or Limit & Stop

Example: If you are selling stocks you don't own.

To quickly place a Sell order using the current order settings (Order Type, Quantity, Duration, etc.), click on the cell in the Ask Size
column that corresponds to the price at which you want to sell (short). If the order type Auto (LMT/STP) or Auto (LMT/STL) has
been selected, theMatrix will automatically specify a Sell Limit or either a Sell Stop-Market or Sell Stop-Limit order based on
whether the selected Ask Size is above or below the current price. If the order type Limit, StopMarket, or Stop Limit is selected,
the Sell order will always be of that type.

Changing the Order Type for Buy and Sell Orders

In the Order Settings section, use the Order Type drop-down list on theMatrix Trade Bar and AdvancedOrders portion of theMatrix
window to change the order type to one of the following:

l Auto (LMT/STP) - Specifies the automatic selection of a Limit or Stop-Market order depending on whether the selected cell is
above or below the current price in the Bid Size or Ask Size column.

l Auto (LMT/STL) - Specifies the automatic selection of a Limit or Stop-Limit order depending on whether the selected cell is
above or below the current price in the Bid Size or Ask Size column.

l Limit - Specifies that a Limit order will be placed using the selected Bid Size or Ask Size cell as the Limit price.
l Stop Market - Specifies that a Stop-Market order will be placed using the selected Bid Size or Ask Size cell as the Stop
price.

l Stop Limit - Specifies that a Stop-Limit order will be placed using the first selected Bid Size or Ask Size cell as the Stop price
and the second selected cell as the Limit price.

Buy and Sell Market Orders

Clicking the or button in the PlaceOrder section, allows you to select the type of market order to be placed using the default quant-
ity. You'll be asked to confirm the order values and, when filled, you should see the resulting position reflected in theMatrix P/L
column.

Buy and Sell Trailing Stop Orders

Clicking the or button in the PlaceOrder section, allows you to select the type of trailing stop order to be placed using the default
quantity. You can choose a trailing stop price based on either a number of points (Pts) or a percentage (%), with a specific value



specified in the Amt field. You'll be asked to confirm the order values and, when filled, you should see the resulting position reflec-
ted in theMatrix P/L column.

VIDEO - Trading with Trailing Stops Using the Matrix

Attach OSO Order

Check Attach OSO and select an OSOOrder template (from theOSO drop-down list). The order specified in the OSO template will
be sent when you place an order from theMatrix window. These secondary OSO orders will become active when the primary mat-
rix order is filled. To change settings for a selected OSO template, click the ellipsis button. For more information, see About
OCO andOSOTemplates or Order Cancels Order & Order Sends Order - Trade Bar.

VIDEO - Attaching a Stop Loss to an Entry Using OSO in the Matrix

VIDEO - Scaling Out of Open Positions Using the Matrix

Place OCO Order

To place anOCO order, select an the desired OCO template (from theOCO drop-down list) and click the PlaceOCOOrder
button. To change settings for a selected OCO template, click the ellipsis button.

VIDEO - Placing Breakout and Fade Trades Using the Matrix

VIDEO - Placing Profit Targets and Stop Losses Using the Matrix

Manage Order(s)/Position

Selecting on the following options will immediately perform the following cancel or close action for the active symbol:

l Cancel/Replace Open Orders - To quickly cancel an open order, click on any cell in the Orders column containing an open
order - the selected order will be immediately canceled. In addition, you can also replace an open order by simply holding and
dragging the order from its initial cell in the Orders column to a new price level in the same column - any unfilled position of the
order will bemoved to the new price level. While dragging, the value of change at each price increment between the original
and new price level will be displayed to show the effect the change will have on the order.

l Canceling All Open Orders - Clicking the Cancel All button on theMatrix Trade Bar will cancel all open Stop and Limit
orders only for the current symbol in the activeMatrix window. Open orders for other symbols will not be canceled.

l Reversing a Position - Clicking the Reverse button on theMatrix Trade Bar will reverse the current position. For example, if
you're long your position will be reversed to be short in one action. It will work the sameway when going from short to long, for
example a position that is short 500 shares will be reversed to be long 500 shares. For Equity symbols that are not 'shortable',
the long position will be canceled resulting in a flat position.

l Closing a Position Immediately - Clicking the Close button on theMatrix Trade Bar will immediately exit the current position
by placing the appropriate market order. You can also click on a cell in the P/L column to instantly place a limit or stopmarket
order at the corresponding price - if there is an existing open order to sell any portion of the position, then that order will be can-
celed and replaced with a new order to close the entire position.

Advanced Trade Bar Settings

From the shortcut menu, select View Advanced Trade Bar to access the advanced order settings such as Activation Rules, If
Touched (MIT & LIT), and others. For more information, see About AdvancedOrders.



Confirm Dialog

To quickly cancel an open order, click on any cell in the Orders column containing an open order - the selected order will be imme-
diately canceled. In addition, you can also replace an open order by simply holding and dragging the order from its initial cell in the
Orders column to a new price level in the same column - any unfilled position of the order will bemoved to the new price level.

Related Topics

About theMatrix Window



OCO/OSOOrders

OCO (Order Cancels Order), Bracket OCO, andOSO (Order Sends Order) are types of conditional orders that can be placed from
the Trade Bar or a Trade Bar in an analysis window.

Click the OCO/OSO button from the Trade Bar and choose anOCO/OSO order from the drop-down list. TheOrder Cancels
Order & Order Sends Order - Trade Bar dialog is displayed.

l AnOCO (Order Cancels Order) order consists of a group of two or more parallel orders that are linked together in such a
way that if one of the orders is filled, then all of the other parallel orders are canceled. For example, let's say that an OCO
order consists of two orders; 1) a limit order to buy 500 shares of one symbol and 2) a stop order to sell 200 share of another
symbol. If the limit price of #1 is hit and fills, the stop order #2 is automatically canceled.

There is no limit to the number of parallel orders in anOCO group of orders. When any one of them is filled, the others in the
group are canceled.

l A Bracket OCO order consists of two exit orders with the same symbol, quantity, and order action (Buy, Sell, etc.). When
one of the orders is partially filled, the other order's quantity is automatically decremented by the same amount. For example,
if you have a sell limit order for 1000 shares and a sell stop order for 1000 shares, and the limit order is partially filled for 500
shares, the stop remains open and automatically decrements to 500 shares tomatch the remaining open position.

l AnOSO (Order Sends Order) order consists of a primary order that will send one or more secondary orders when the
primary order is filled. For example, there is anOSO order consisting of three orders, where the primary order 1) is a limit order
to buy 1000 shares of a symbol, and attached to it are two other orders: 2) a limit order to buy 500 shares of another symbol in
the same industry and 3) a stop order for 1000 share of the primary symbol at a specified price below the limit price for that
order. When the primary order is filled, the two additional OSO orders are sent: one that buys additional shares of a related
symbol, and another that sets a stop loss for the primary symbol.

Related Topics

About OCO/OSO Trade Bar

OCO/OSOColumns and Fields

OCO andOSOTemplates

Custom OCO andOSOOrders

Changing OCO/OSO Templates Preferences

About Trade Bar



Using Chart Trading

TradeStation Chart Trading is an application that allows you to quickly and easily place trades, manage positions, andmanage
orders from a chart. It integrates click-and-drag order placement functionality and ease-of-use to a Chart Analysis window.

Similar functionality as above is available in theMobile andWeb Trading versions of TradeStation.

To apply chart trading to the active chart in the desktop platform, select Chart Trading from the shortcut menu or click the Chart

Trading icon from the Chart Analysis toolbar. The ChartTrading panel appears and docks to your chart window. Using
ChartTrading also appears with popular speed keys for placing trades.

VIDEO - Enabling Chart Trading in Chart Analysis

If the Chart Trading icon does not appear on the toolbar, use the Toolbar Options > Customize menu sequence to
access the Customize dialog, and under the Commands - Chart Analysis Toolbar category drag Chart Trading to the pos-
ition you want the icon to appear on the Chart Analysis toolbar. See Customize - Commands for more about customizing the
toolbar.

VIDEO - Placing Limit and Stop Orders Using Chart Trading

Trades can be placed by clicking on the various order entry buttons in the Order Panel or by clicking directly on the chart. The chart
trading order bar is much like the Quick Trade Bar and integrates click-and-drag order placement functionality that is similar to that
found in theMatrix.

VIDEO - Placing Breakout Trades Using Chart Trading



Placing Orders Using the Chart Trade Bar

Order Settings

l Account Number - The Account to use for your trades in this chart.
l Order Quantity - The number of shares, contracts, or lots to trade.
l Order Duration - The duration type of the order.
l Attach OSO - Check to attach the listed OSO order type.
l OSO Order Types - Drop-down list of available OSO orders.

Place Order

l Buy - Buy Limit at the best Bid price (Bid size shown under Bid price).
l /\ or \/ - Upward or downwardmarket direction.
l Sell - Sell Limit at the best Ask price (Ask size shown under Ask price).
l Buy Mkt - Buy at current market price.
l Sell Mkt - Sell at current market price.
l Take - Buy Limit at the best Ask price.
l Hit - Sell Limit at the best Bid price.
l Buy Trl - Buy with trailing stop.
l Sell Trl - Sell with trailing stop.
l % or Pts - Trail by percent or number of points.
l Amt - The value (% or Pts) for the trailing order.
l Place OCO Order button - Click to place the listed OCO order.
l OCO Order Types - Drop-down list of available OSO orders.

Manage Orders/Position

l Cxl All - Cancel all open orders for the symbol.
l Cxl Active - Cancel open orders in the current session.
l Reverse - Reverse the side of your open positions.
l Close - Close your position.
l VWAP - Volumeweighted average price of your position.
l Position - Size of current position.
l AvgPrice - The average price of current position.
l OpenP/L - The profit (positive) or loss (negative) of the current position.
l OpenP/L% - The percent profit (positive or negative) of the current position.

Disable -When checked, disables order panel.

Help- Displays online help.

Place Orders by Clicking in a Chart

When placing orders by clicking on the chart, Ctrl + Left Click mimics the behavior of clicking on the bid side in theMatrix window
and Alt + Left Click mimics clicking on the ask side in theMatrix window.

l Open orders can bemoved to new price levels by simply dragging their corresponding order lines.
l Right-clicking an order line will allow you to edit the order's quantity and/or price.
l Selecting an order line and pressing the delete key will delete the order.

The following table summarizes the various key andmouse click combinations that may be used to place orders by clicking dir-
ectly on the chart:



Key + Mouse Click Combination Order Action

Ctrl + Left Click (Below the Ask) Buy Limit @ selected price

Alt + Left Click (Above the Bid) Sell Limit @ selected price

DELETE key onOpenOrder Line Cancel Order

Related Topics

Chart Trading (Indicator)

Quick Trade Bar for Equities and Futures

Quick Trade Bar for Forex

http://help.tradestation.com/09_05/eng/tradestationhelp/subsystems/elanalysis/indicator/chart_trading_indicator_.htm


Placing Orders using Activation Rules

This order feature allows you to determine when an order will be sent to themarket based on either a specified time or price action
of one or more symbols. Activation rules for a given order are specified using the Activation Rules option.

Activation rules are only active during the regular session.

VIDEO - Using Time and Price Activation Rules in the Trade Bar

Placing a Time-based Activation Rule

1. From the Trade Bar, click Advanced.
2. Place a check mark next to Activation Rules.
3. Click . The Activation Rules dialog is displayed.
4. Place a check mark in Time and enter a time that the order is to be routed to themarket.
5. Click OK to save the time rule.

A time-based activation rule is only evaluated during the first active regular session after the order is created.

Placing a Price-based Activation Rule

1. From the Trade Bar, click Advanced.
2. Place a check mark in Activation Rules.
3. Click the ellipsis button. The Activation Rules dialog is displayed.
4. Place a check mark in Price.
5. Enter a symbol, or click Lookup to lookup the symbol.
6. Click Add. The symbol will be displayed in the Activation Rule field.
7. Edit a conditional operator (>, >=, <, <=), value (target price), and activation trigger type for each symbol. This will determine

each of the price conditions used to activate the order. You can also specify how multiple conditions (up to four) are combined
by using the 'And' and 'Or' expressions (the default is 'And'). To remove a condition, click on the X.

8. Click OK to save the price rule.

All of the Activation Rule conditions must be true for the order to become active. For example, if an activation time of =>
3pm (equal to or greater than 3pm) is set and a trigger price is selected for a symbol, the order will become active only if the
time is 3pm or greater and the symbol reaches the price target. For a GTC order, if the price-based and time-based rule con-
ditions are not met during the first active session after the order is created, then only the price-based conditions will continue
to be tested on successive sessions until the GTC order is filled or canceled.

Related Topics

"Placing Orders using Activation Rules" above



About the Position Graph Bar

The Position Graph Bar is used to keep track of selected account positions and quotes by using a colored bar graph format. By
default, it is docked to the Position Graph tab at the top of the desktop; however, it can bemoved or resized. Position graphs are
plotted from zero to your current profit or loss. They use a common scale by default to show each symbol's profit or loss in relation
to your maximum run-up or maximum draw down. Use the shortcut and customizemenus to change settings.

To display or hide the Position Graph Bar, use the View > Position Graph Bar menu sequence.

VIDEO - Monitoring Positions in the Position Graph Bar

Layout

Quote Bar

TheQuote Bar section of the Position Graph Bar displays the last and net change, and net percentage change, for the symbols
(quotes) that you select. By default, the Dow Jones, Nasdaq, and the S&P 500 are displayed, yet other quotes can be added or
removed by using the Customize Position Graph Bar - Quotes tab.

Position Graphs

The position graphs show real-time profit and loss status for your open and closed positions.

By default, position graphs for up to 150 positions are displayed, and you can customize the position graphs in several ways.
For example, you can filter the position graphs, change the sort order, andmodify the settings. For more information, see Cus-
tomize Position Graph Bar - Positions tab.

Winning positions are displayed in green and losing positions are displayed in red. Flat positions are differentiated from the
open long and short positions by a preceding null (Ø) sign. The closed P/L for the current trading session with themaximum run
up and draw down are displayed for each flat position graph bar. Flat positions are colored by a darker shade (to the winning or
losing color shade) as compared to the open positions.

Position graphs can be displayed in account currency, symbol currency, or by percentage. There are a number of other options
you can access from the shortcut menu on the Position Graph bar.

Click the arrow to scroll to see additional positions. Use the Customize Position Graph Bar - Positions tab to change the sort
order; for example, by most profitable or by symbol and tomodify other Position Graph Bar settings.

Hover over any of the position graphs to view a tooltip showingmore details. To customize the tooltip, use
the Customize Position Graph Bar - Tooltips tab.

View More Graphs

To see additional position graphs, click the scroll arrow at the far right of the Position Graph Bar. Use the Sort section of the
Customize Position Graph Bar - Positions tab to change the sort order; for example, by most profitable or by symbol.



Additional Controls

Auto Hide on/off

Click the pushpin icon to turn off Auto Hide so that the bar displays all the time.

Click the pushpin icon to turn on Auto Hide so that the bar only appears when themouse pointer hovers over the Position
Graph tab.

Move the Position Graph Bar

By default, the Position Graph Bar is docked to the Position Graph tab at the top of the desktop.

Click the drop-down arrow and select or deselect menu choices. For more information about displaying, hiding, andmoving
bar panels, see About Bar Panels.

Related Topics

Close and Reverse Positions using the Position Graph Bar

Display the Position Graph Bar in Currency or Percentage

Reset the Position Graph Bar

Customize the Position Graph - Positions

Customize the Position Graph - Quotes

Customize the Position Graph - ToolTips



About TradeManager

The TradeManager window displays trade and account activity. All orders are logged to the TradeManager window on a real-time
basis when TradeStation is open. Orders are color-coded so you can differentiate between different order statuses at a glance. The
colors are updated in real-time as the status of your orders changes. You can also quickly close positions and cancel orders from
the TradeManager window, as well as view your order history.

Create a TradeManager window by clicking the TradeManager icon on the Apps tab. A new TradeManager window is dis-
played.

Layout

The filter bar is located in the upper section of the TradeManager window. Below the filter bar, there are several tabs where order
information is viewed.

Toolbar - Provides drop downmenus that control the features and settings of the window.

Filter Bar - Allows you to view orders for a specified symbol filter. Also, lets you filter based on account number, order status,
and date range.

To view or hide the filter bar, use the View > Account Filter Bar setting.

Detail Pane - Displays information for the selected tab.

Tabs - Each tab contains columns that you can use to sort your account information, as well as filters.

l Orders
l Average Price
l StagedOrders
l Positions
l Strategy Orders
l Strategy Positions
l Balances
l Messages
l Allocations (need entitlement access)



To add or remove columns, right mouse-click on any column name to view the shortcut menu, and choose Customize
Columns. For more information, view the Customize Columns and Rows help topic. For column descriptions, see the
TradeManager Column Library.

Related Topics

Canceling anOrder in TradeManager

Closing or Reversing a Position in TradeManager

Setting UpOrder NotificationMethods

Customizing TradeManager

Managing Strategy-Generated Orders in TradeManager

Viewing your Order History

TradeStation Client Center and Tax Preparation

Similar functionality is available in theMobile andWeb Trading versions of TradeStation.

http://help.tradestation.com/09_05/eng/tradestationhelp/subsystems/elanalysis/el_libraries/trademanager_column_library.htm
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